Difference between revisions of "Use with AnalysIR"

From AnalysIR WiKi
Jump to navigation Jump to search
m
m
 
Line 3: Line 3:
 
If you have purchased a copy of AnalysIR, you can also use KontrolIR with AnalysIR. AnalysIR adds the possibility to record signals along with carrier frequency. You can also clean recognised signals for better performance and test sending of signals. Finally, you can export signals in IRremote format via '''''Menu->File->Batch Export->IRremote''''' (or IRLIB)
 
If you have purchased a copy of AnalysIR, you can also use KontrolIR with AnalysIR. AnalysIR adds the possibility to record signals along with carrier frequency. You can also clean recognised signals for better performance and test sending of signals. Finally, you can export signals in IRremote format via '''''Menu->File->Batch Export->IRremote''''' (or IRLIB)
  
'''''If you have not purchased a copy of AnalysIR, you should ignore this section.'''''
+
'''''If you have not purchased a copy of [https://www.analysir.com/blog/shop/ AnalysIR], you should ignore this section.'''''
  
 
AnalysIR Firmware
 
AnalysIR Firmware

Latest revision as of 05:29, 13 January 2020

> KontroLIR Home

If you have purchased a copy of AnalysIR, you can also use KontrolIR with AnalysIR. AnalysIR adds the possibility to record signals along with carrier frequency. You can also clean recognised signals for better performance and test sending of signals. Finally, you can export signals in IRremote format via Menu->File->Batch Export->IRremote (or IRLIB)

If you have not purchased a copy of AnalysIR, you should ignore this section.

AnalysIR Firmware

  1. First request the AnalysIR firmware sketch from us by email, if you don't already have it. (File Name: sketch_AnalysIR_KontroLIR_401.ino)
  2. This firmware can only be used when you connect your KontroLIR to your PC running AnalysIR via the SerialUSB adapter.
  3. Note this is firmware is for use with our AnalysIR application only. (The full KontroLIR firmware for remote control operation is different). You will receive a copy of this firmware source if you order the dual IR receivers option when purchasing your KontroLIR remote and have also purchased a copy of AnalysIR.
  4. Make sure you have installed support for the ATmega328PB platform or core, into the Arduino IDE. (see Getting Started for instructions )
  5. Make sure to try out the example Arduino blink sketch or an example Serial print sketch to verify correct operation of the ATmega328PB with your Arduino IDE, before proceeding to use any KontroLIR or AnalysIR firmware.
  6. Remove the batteries and connect the Serial USB adapter to KontrolIR.
  7. Insert the USB cable into the PC running AnalysIR & the Arduino IDE.
  8. Select Board "ATmega328PB Crystal Clock" from the Tools->Board Menu of the Arduino IDE.
  9. Select the correct COM port number of the serial USB adapter, in the Arduino IDE menu.
  10. Select clock speed of 16MHz for the AnalysIR firmware.
  11. Compile the firmware. (You can ignore the warning message about low memory availability)
  12. Upload the firmware to the KontrolIR device.
  13. Close the Arduino IDE.
  14. FYI: with this firmware we use a 16MHz clock rate & 115200 BAUD (vs 4MHz clock rate & 19200 BAUD for KontrolIR firmware). Make sure to select the correct clock rate in the IDE when switching firmware. This firmware is functionally equivalent to the firmware for our A.IR Shield Nano - with changes made for the different hardware & timers used.
  15. The image below shows the location of the Dual IR receivers inside the KontroLIR remote. They are located behind the highlighted buttons, which allow Infrared Light to pass through.

IR Receiver location inside KontroLIR.jpg


Follow these steps to get started with AnalysIR:

  1. Remove the batteries and connect the Serial USB adapter to KontrolIR. (If not already removed)
  2. Insert the USB cable into the PC running AnalysIR.
  3. Start AnalysIR, if not already running.
  4. Select the COM port number of the serial USB adapter from the drop-down at the bottom of the main AnalysIR window.The box should turn green.
  5. Select A.IR Shield Nano(in future versions of AnalysIR select KontroLIR) from the Source menu, in AnalysIR
  6. You are now ready to use KontrolIR as an IR source and IR emitter from AnalysIR.
  7. Refer to AnalysIR documentation on how to use AnalysIR.

Congratulations! - you are now ready to capture and send IR signals from within the AnalysIR application.

If you ordered the IR receiver pair option when ordering KontroLIR, you can use the Rx & Tx features of AnalysIR. If not, you can only use the Tx feature from AnalysIR. (the same applies for use with IRremote)

Note: You can purchase a copy of AnalysIR from our shop.

It is possible to customise KontroLIR using just IRremote without purchasing a copy of AnalysIR. However, AnalysIR is the leading tool available for recording and reverse engineering IR signals and is a powerful addition to any IR toolbox. KontroLIR can also work directly connected to AnalysIR (with the appropriate firmware loaded) and is supported for both sending and recording IR signals. (IR receiver option is required for recording signals with AnalysIR or IRremote)

> KontroLIR Home